This mod is intended to be run on Patch 1.31, see Patch Level Compatibility.


As this is a core-mod, you must ensure that you are running the version that matches your Patch-level. Do not attempt to run this mod on anything but the aforementioned Patch.



MOD


This is a core-mod intended to catch and correct data corruption errors that can render a save-game unloadable.

Any corruption errors that can not be corrected will be trapped and logged, allowing the save-game to load regardless.

Unhandled script errors may be posted on the ErrorTrap Issues page for evaluation and possible repair.
  • There are instructions on that page on how to find and upload log files

DOCUMENTATION


A list of existing errors, and how to resolve them is here : Reading ErrorTrap Logs

A list of enhancements under consideration is available here : The List

A list of known issues is available here : Issues

NOTES


This is a Core-Mod which overrides the "ScriptCore" S3SA file, and will conflict with any other mod that overrides that file.

Use Delphy's Dashboard to test this mod for any conflicts with other installed core-mod prior to use.

TUNING


This mod is XML tunable. Optional tuning packages are available here : Tuning

WARNING


As always, ensure that you backup your save files prior to installation of this mod. As Murphy said: If anything can go wrong, it will go wrong.

UPDATES


Revision Notes can be found here : Revision Notes

FILES


Instructions on how to install these files are available here : How to Install

There are two versions of this mod :
  • Install the correct one for your installation, or you will receive an error message on start-up

This one is for games downloaded from Steam (to be used only by digital downloads from Steam)

This one is for everyone else (either physical DVD users or digital downloads via EA's Origin service)