MOD


This mod's purview is the manipulation of the transition system used to transport sims back and forth between towns.

NOTE:
  • This mod does not unlock World Adventures traveling on its own.* You will require the Pack installed to travel in that manner.
  • Subsequent Expansions have since added additional transition methods. They all run through the same process though, and are all covered by the mod.
    • Note that you still need the appropriate Expansion pack installed to unlock the functionality.
    1. World Adventures Vacation Travel
    2. University College Enrollment
    3. Island Paradise Move To New Town
    4. Into The Future Time Travel

*Note that beginning with v86 of Traveler, which requires Patch 1.66 or higher, the requirement to have the World Adventures EP installed for vacation style travel to other worlds has been lifted.

WARNING:
When you decide to start a new game after a game session, exit the game completely and restart from desktop. When doing it through the main menu, such as Save current game - switch to Main menu - Start New Neighborhood, all existing in-world deceased Sims will be resurrected and dropped on a Venue or Empty lot chosen as their Residential home.
This might lead to corruption on that current game, so please Exit current game session and restart the game from desktop.

Confirmed test with V86 (patch 1.67) by - J4Ks J4Ks


DOCUMENTATION


A full listing of all interactions and details regarding their use are available here : Interactions

There is a FAQ available here: FAQ



ISSUES


To report issues related to this mod go here : Traveler Issues



VERSIONS


Ensure that you download and install the Phase that works on your Patch-Level.

Module
Phase
Patch Level
Description
Base-Mod
Seven
1.66-1.69
Required to run all the other modules, or is the sole package required for the mod.

OLDER VERSIONS


Module
Phase
Patch Level
Description
Base-Mod
Seven
1.63
Required to run all the other modules, or is the sole package required for the mod.
Base-Mod
Six
1.55-1.57
Required to run all the other modules, or is the sole package required for the mod.
Base-Mod
Five
1.50
Required to run all the other modules, or is the sole package required for the mod.
Base-Mod
Four
1.42-1.48
Required to run all the other modules, or is the sole package required for the mod.
Base-Mod
Three
1.38-1.39
Required to run all the other modules, or is the sole package required for the mod.
Base-Mod
Two
1.31-1.36
Required to run all the other modules, or is the sole package required for the mod.
Base-Mod
One
1.29
Required to run all the other modules, or is the sole package required for the mod.